dcsimg
Results 1 to 3 of 3

Thread: Bryant Plus 90 398AAZ won't start

  1. #1

    Default Bryant Plus 90 398AAZ won't start

    Installed Bryant Plus 90 398AAZ furnace in 1991 as a backup to a heat pump so it was rarely used until 2006 when the heat pump died and it became the primary system. Furnace heats the 1st floor only. Since 2006 there have been 5 occasions (today being the 5th) when I wake up to a cold first floor - thermostat timer goes on at 6am, off at 10pm. On 2 of the previous occasions, I turned the thermostat off, waited a few minutes and turned it back on and there was heat, on one occasion it took several on and off attempts but it eventually came on.

    Then there was the time last year when nothing worked so I called a serviceman. He came out opened the unit, checked wires, turned the switch on and off, turned the breaker on and off and nothing would work. He said that it was probably the Fan Blower Control Board or the Inducer Control Board, as he pointed here and there in the open unit. He said that he'd look into some prices for me and call the following day. He then put the bottom panel back on, pushing in the interlock switch and voila, the unit came on. He offered to continue but I told him to leave it on at least until the floor was warm. He said to call him if it happened again but not to switch anything on or off so he could possibly see what the trouble was. That was over a year ago. The heater worked fine for the rest of last year's heating season and has worked fine for all of this, until this morning.

    I've found issues with this furnace, on this forum and other forums but not this problem (except there was a suggestion to check for fuses on internal boards being blown, which I did). As an aside, I bought both of the boards that he mentioned but never installed them. Still have them.

    Does anyone have any suggestions? This time could it be one of the boards? Which one? Any troubleshooting tips? Any help appreciated.

  2. #2

    Default

    The unit's back on and like the other times, I have no idea why. I'm leaning toward a relay as part of the problem. Three times, it has gone back on without touching the furnace, just switching the thermostat off and on; once it took a few attempts. When I called the serviceman last year, he had given up, was packing up, putting the unit back together. He put the lower panel on, pushing in the interlock switch, and before he got the upper panel on, we saw flame for the first time in an hour of fiddling with wires and boards. Putting on that panel, like turning the thermostat on and off causes that relay to engage. Yesterday, I was doing the same thing. I had given up, considering my next move, and noticed when I pushed in the interlock, a spark appeared in the left relay on the Fan Control Board, I pushed it 3 or 4 times to confirm that the spark always appeared, closed the unit up, and before I made it to the stairs, I heard the flame ignite.

  3. #3
    Join Date
    Dec 2003
    Location
    Kent, WA
    Posts
    8,431

    Default

    There are so many things it could be it is impossible to guess without more information. Does this furnace have a diagnostic light or display to give some clue as to why it isn't happy? It could even be the door interlock switch. You may just want to tape it down or jumper it and put a sign on the door indicating "door interlock bypassed". It makes troubleshooting easier anyway to watch it with the door off, you just need to keep your hands out of harms way.
    Mark
    Kent, WA

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •