dcsimg
Page 1 of 9 123 ... LastLast
Results 1 to 10 of 84

Thread: Malfunctioning GE Profile Bottom Freezer Fridge

  1. #1

    Default Malfunctioning GE Profile Bottom Freezer Fridge

    Hi, Our GE Profile Bottom Freezer Fridge is malfunctioning. I provided more details below. Is this user fixable? Anyone have a service manual?

    1. Model: PDS22SBRALSS
    2. Problem:

    Freezer appears to be working (keeps thing very cool) but fridge
    part not. No really cold air into fridge part. Its at 66F while the
    freezer is at near -13 (offsale). Fan is always on.

    All vents appear to free of debris. Noticed that the
    some vegetables in the vegetable trays/crispers were frozen
    before it all happen.

    3. Some of (my!) guesses:

    It sounds like something is blocked the cold air from going up from
    the freezer to the fridge.


    Help!
    IP

  2. #2

    Default

    Hi,

    Freezer appears to be working (keeps thing very cool) but fridge
    part not. No really cold air into fridge part. Its at 66F while the
    freezer is at near -13 (offsale). Fan is always on.
    It sounds like something is blocked the cold air from going up from
    the freezer to the fridge.
    A frost free failure would be prime suspect. If the cooling/evaporator coils frost over the air flow is chocked off and the evaporator fan motor can no longer draw air across the cooling coils and blow the colr air into the fresh food section. GE doesn't put manuals online.

    If needed:


    Thermostat-bi-metal


    Thermodisc

    No pic
    Defrost heater

    If above parts ohm/test /check ok, the board is then suspect.


    Main control board

    jeff.
    Appliance Repair Aid
    www.applianceaid.com
    JRAppliance
    www.jrappliance.ca
    IP

  3. #3

    Default

    Hi Jeff,

    Thanks. I'll investigate based on what's you've described. I was in a panic this afternoon when we realized that the fridge was out and consequently didn't have a chance to read through the other sections of your wonderful website - I found your website by accident (and I'm glad I did) Will advise. Thanks.
    IP

  4. #4

    Default

    Will advise
    Please do

    jeff.
    Appliance Repair Aid
    www.applianceaid.com
    JRAppliance
    www.jrappliance.ca
    IP

  5. #5

    Default

    Hi Jeff,

    Apparently there is some sort of way to get the fridge into a self test mode by pushing all of the temperature controls. I've seen some references to getting the indicators to "5" first and then pushing them all for 3secs. This may apply to another model as the fridge temperature setting only goes between 34 - 47F on mine. There must be another "secret" sequence to push on my PDS22SBRALSS. Any hints?

    Thanks.
    IP

  6. #6

    Default

    Tech sheet is often behind the lower front grill in an envelope.

    Most often we just check/ohm the defrost heater and thermostats, if ok the board is then suspect. Most ( not all ) of the GE refrigerators don't have a forced defrost.

    jeff.
    Appliance Repair Aid
    www.applianceaid.com
    JRAppliance
    www.jrappliance.ca
    IP

  7. Default PDS22SBRAL22 issues, GE Profile Bottom freezer

    I too am having problems with this fridge.
    I bought it in April 2004.
    Then in July 2006 I found the fridge & freezer very warm and all food spoiled.
    I pulled the power from the fridge for 20min. I plugged it back in and I heard it turn on. But the fridge/freezer would not chill.
    SEARS came by and put in a new circuit board.
    Everything seemed fine.
    Freezer-0, Fridge-37 (Temps seemed stable).

    I should note that SEARS showed up with a new main board (P/N: WR55X10416) and an instruction manual that informs the technician to cut wire #2 from Terminal/Connector "J1". Apparently this wire is connected to a thermistor.
    This instruction sheet also said to cut the ground wire from the compressor harness. This new board came with new earth ground connections.
    Which my old board didn't have.
    I'm guessing this grounding rewire is related to inductive noise from the compressor?
    Oh..my old board number was WR55X10339

    So now it's April 2008 and I'm finding my temps are riding low and high, and opposite to each other. So, if my fridge is warm, then my freezer is colder.
    For example.. (Defaults are 37F & 0F)
    Freezer -3F and fridge 42F
    Or,
    Freezer 1F and fridge 33F

    SEARS comes back.
    We find that the condensor fan isn't spinning and the compressor is quite warm. SEARS orders a FAN & Main-Board and says they will return in 3 days.
    In the meantime I put the old board in and right away the compressor kicks in and the fan starts. I examine the board and find the processor pin that drives the sinking transistor for the fan. Its a square wave at roughly 1khz, 10% on, 90% off.
    So I put the second board back in (Which is the most recent board).
    I lift the fan pin at the processor and feed in a square wave signal from my fun-gen. Fan is now on. After a couple of hours, the fridge temps are better.

    SEARS returns and is a little surprised to find my fun-gen tapped into the main board. I should admit I am a Controls Eng and I design Controls systems. I design and layout circuit boards as well.
    SEARS is also glad to know the fan is working.
    The fan is $239.99 (WR84X10055)
    So only a new board was needed. $174.99 (WR55X10552).

    Now I have a new (3rd) board and temps still seem to floating around quite a bit. But I have yet to go grocery shopping, so my fridge is only 30% full. My freezer is about 30% as well.

    I can hear the fridge do it's gurgling thing every so often.
    And it makes that sucking sound after I shut the door.
    But the fan is always running?? Should it be?
    I don't mean the compressor fan, I mean the one you hear inside the fridge.
    I don't recall it always running before?

    If anyone has this fridge.....does this fan run all the time for you?

    Now my fridge is reading 1F and 33F.


    In regards to cutting this wire at J1.
    Should this have been done? The installation sheet says this should be done for
    all "Encoder Models with the following serial numbers..................."
    My fridges serial starts with AR and is NOT in the list...

    Bob
    Last edited by Bob-tech; April 5th, 2008 at 03:53 PM.
    IP

  8. #8

    Default

    Hi,

    GE has had there problems with that board

    But the fan is always running?? Should it be?
    I don't mean the compressor fan, I mean the one you hear inside the fridge.
    I don't recall it always running before?
    Nope, normally the evaporator fan motor should not run all of the time.

    In regards to cutting this wire at J1.
    Should this have been done? The installation sheet says this should be done for
    all "Encoder Models with the following serial numbers..................."
    My fridges serial starts with AR and is NOT in the list...
    My sheet says the same...

    STEP 2 ELIMINATE THERMISTOR WIRE
    IN PIN 2 OF J1 CONNECTOR
    (See note below) IF NO WIRE IN
    PIN 2, PROCEED TO STEP 3

    NOTE: This step is ONLY applicable for the following models:
    All BOTTOM FREEZER models
    ENCODER models with the following serial number prefixes: TD2, VD2, ZD2, AF2, DF2, FF2, GF2, HF2, LF2, MF2, RF2, SF2

    jeff.
    Appliance Repair Aid
    www.applianceaid.com
    JRAppliance
    www.jrappliance.ca
    IP

  9. Default

    Jeff,
    I read...
    All BOTTOM FREEZER models
    ENCODER models with the following serial number prefixes: TD2, VD2, ZD2, AF2, DF2, FF2, GF2, HF2, LF2, MF2, RF2, SF2


    As.... Bottom freezers with Encoder models.
    So this wire cut takes place on all bottom freezers, and encoder models?

    Today my temps are 0F & 41F for the fridge.
    With the old board the temps were solid.

    >>Nope, normally the evaporator fan motor should not run all of the time.
    It must be this board running the evap fan?
    I am also hearing the compressor kick in every so often....

    Do you think it'sthe evap fan that's causing my temps to float around so much?
    Or is there something wrong another sensor.?

    Bob
    IP

  10. #10
    Join Date
    Nov 2004
    Location
    Boston, MA
    Posts
    1,511

    Default

    Interesting
    I have a GE side by side HMDSL26DHWA (maybe 2 weeks old) & 3x now I have found the freezer running & going down to -4, -7 & -9
    The fridge has stayed at temp (3
    The freezer setting at 3 degrees
    DIY Homeowner...not a Pro or licensed electrician
    IP

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •